Introduction
The client encountered the App not found error in Teams when installing the MSPbots app.
Possible Causes
One of the following may be causing this error:
- Office 365 is set to block the installation of new apps.
- MSPbots is not properly installed.
Prerequisites
You’d better have Microsoft Teams Global policy before proceeding. Refer to How to Add MSPbots to the Teams Global Policy for instructions on how to add it. If you don’t, the Teams Admin can also help fix the error.
Solutions
Do the following to fix the error:
- Set MSPbots to be Allowed in Teams. Use this guide to check if Teams is set to block the installation of new apps.
If this did not resolve your issue, proceed to the next step. - Reinstall MSPbots properly using any of the following methods:
-
Install MSPbots from Microsoft AppSource.
If you want to access MSPbots in Microsoft AppSource, refer to MSPbots. -
Install MSPbots from Microsoft Teams.
If you want to install Microsoft Teams, refer to Install Microsoft Teams.
If these did not resolve your issue, try the next step.
-
Install MSPbots from Microsoft AppSource.
-
Setup Teams Global Policy to push MSPbots to all users.
If your issue remains unresolved after performing the above procedures, submit a request through our Help Center for assistance.