N-able N-central provides full visibility into both on-premise and cloud-based networks. It lets you map client networks, deploy templates, and implement automation policies with ease. Integrating N-central with MSPbots elevates IT management by providing real-time notifications and BI automations, adding better efficiency and faster decision-making.
This article provides a step-by-step guide for connecting N-able N-central to MSPbots, including information on known issues that may arise during the setup.
Prerequisites
You must have the following to establish a successful connection:
- Active N-able account
- N-able Benchmarking license
- Admin role and permissions for setting up the integration
Setting up the N-able N-central integration
-
Create an API-only user and turn off Two-Factor Authentication.
- Set the default administrator role.
- Set the default administrator group.
- Select MFA Not Required.
- Select API-only user.
- Scroll down and click Save.
- (Optional) If you require Warranty Expiry Date information for your device,
- Reach out to N-able N-central technical support to authorize and activate the Warranty Expiry Date feature on your N-Central server.
- Reactivate your N-Central server by yourself.
- Upon completion, MSPbots will automatically synchronize the Warranty Expiry Date information for your device.
For further details, see How to get Warranty Expiry Date from DeviceGet API call to N-able N-central API using SOAP calls.
- Set the default administrator role.
- Log in to the MSPbots app and go to Integrations.
- Search for N-able N-Central and click it to open the configuration settings.
- In the API URL field, enter <server address>, where <server address> is the FQDN or IP address of your N-able N-central server.
Remove all the trailing slashes from the FQDN or IP. Example: If the URL is http://Your_FQDN_or_IP/dms2/servicexx/Servexxx?wsdl, use http://Your_FQDN_or_IP -
Enter the User Name and Password of the API-only user.
-
Click Save And Sync.
Known issues
-
Error Authorization failed
The N-able N-central integration displays the error "Authorization failed" in the MSPbots app.
This error may be due to an inactive or disabled user account in N-central. To resolve this issue, please contact your administrator to confirm that your account status is active. Once it's confirmed that your account is active, please reconnect and reauthorize your connection to MSPbots.
-
Error: Unable to validate UI session
An API status for the N-able N-central Integration has failed with the error "java.lang.reflect.InvocationTargetException: Unable to validate UI session.
Possible Cause
- An expired password. N-able expires passwords every 90 days, by default.
Solution
- Reset your N-able N-central password.
- Reauthorize MSPbots successfully, see the Setting up the N-able N-central integration section.
- Due to the data volume and API rate limiting, wait for 1-3 days until the next synchronization cycle is completed. The cache will be automatically refreshed when the next sync cycle begins, and the synchronization will run normally.
- If the issue persists, please submit a request to our Support team.
-
Error: User account is locked
The integration has a "Failed" status, and the sync history shows the error "User account is locked."
Possible causes
- Invalid credentials or an expired password. N-able enforces a 90-day password expiration policy by default, which might be causing the authentication error.
- Repeated failed attempts to log in. The expired credentials might have prompted the user to log in repeatedly, triggering a security lock on the user account.
Solution
- Unlock the user in N-able N-central following the instructions in the N-central User Guide for unlocking a user.
- Reset the N-able account password to comply with the 90-day policy.
- Re-authorize MSPbots in N-able N-Central.
You can refer to N-able N-central Integration Setup for Steps 1 and 2. - If the error persists, the integration possibly needs a synchronization reset. Please contact the MSPbots Support team.