ConnectWise users have reported that the deleted tickets and data continue to appear in MSPbots widgets. Sometimes, the number of tickets in their Next Ticket for ConnectWise Manager application is higher than expected.
Root Cause
After investigation, we found that these issues are caused by previously deleted tickets that were not completely purged from integrations.
MSPbots uses incremental updates, retrieving only cumulative updates like ticket status changes, server offline events, and new time records for technicians.
When using APIs that do not support notifications for data deletion, systems are not notified when a ticket is deleted or updated in the database. As a result, the MSPbots system cannot determine which tickets have been deleted or updated.
Because the ConnectWise API does not support webhooks, MSPbots also does not receive real-time notifications every time a ticket is deleted. Deleted product records are not automatically removed during normal incremental syncs. As a result, you may continue to observe deleted ticket information or an excessive number of tickets in the MSPbots and NextTicket applications.
Why doesn't MSPbots implement a complete data synchronization process to automatically update ticket information and prevent this issue?
MSPbots also has other APIs that utilize a complete synchronization method. However, for the deleted tickets issue, we are currently unable to perform a complete data synchronization because doing such increases the risk of API rate limit issues Currently, we can handle large amounts of API data more efficiently through an incremental data synchronization process, which does not include deleting data.
Prerequisites
- Only admins can manually delete data to solve the issue.
How to fix the issue
Delete the tickets manually
The residual tickets that did not sync after deletion can be removed using the MSPbots API Tool. If your data is synchronized using the following APIs, please ask the admin to delete it manually to resolve the issue.
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Below is a screenshot of the API Tool.
Which tickets require manual deletion?
APIs that do not support notifications for deletion notifications and have a time range exceeding 30 days cannot be deleted automatically, requiring admins to delete the unsynced tickets manually.
Due to the issue ESCALATE-734 in ConnectWise Manage, MSPbots cannot synchronize complete data through the Reports Service API, which also does not support delete notification. Manual deletion is likewise needed for tickets synced via this API.
Weekly Synchronization
MSPbots has also increased incremental sync frequency to improve detection of new data and address the issue. Additionally, a weekly full compensation sync has been implemented to automatically clean up deleted ticket data, thereby preventing issues related to the API rate limit.
Unaffected tickets and datasets
Not all datasets remain unchanged or unsynced. The APIs supported by webhooks will be updated promptly. The following are the data types that will be automatically deleted:
- Data synchronized through the following APIs with callback support for data deletion notification.
- activity
- agreement
- contact
- configuration
- invoice
- expense
- opportunity
- project
- purchaseorder
- company
- ticket
- schedule
- time
- Data that is synchronized through the APIs that do not support data deletion notifications but support notifications for data updated within 30 days after synchronization
Depending on the volume, MSPbots will perform data deletion checks and automatically remove data for these updates within the 30-day range.