The Writeback Info field of a ticket in the Triaged Tickets widget on the AI Ticket Triage Overview for the ConnectWise Manage dashboard of your AI Ticket Triage for ConnectWise Manage app displays the following error message:
| Error calling PSA API: Failed to update PSA. Response code: 400, ......, This company is in a status that does not allow saving Service Ticket. |
Possible Cause
It may be because the Company Status of the ticket set in the ConnectWise Manage app is incorrect.
Solution
- Sign in to ConnectWise Manage app using the account that authenticates the ConnectWise integration in the MSPbots app.
- In the ConnectWise Manage app, open the ticket with the error message displayed in the MSPbots Writeback Info field and click Company.
-
Check and note the value of Status, for example Active.
- Go to System > Setup Tables.
- Enter Company Status and search for it, then click Company Status link.
- Click the status you noted in Step 3, such as Active.
- Clear the Disallow Saving checkbox.
- Click
to save your changes.
- When You have successfully updated this record appears, it indicates that your changes were successful.
- Go back to the MSPbots app and refresh it.
Contacts
If the error message still exists, submit a support request in the Help Center for help.